请选择 进入手机版 | 继续访问电脑版
快捷导航

k8s apply yam文件【报错】error: unable to recognize

2
回复
606
查看
[复制链接]

7

主题

15

帖子

54

积分

注册会员

Rank: 2

积分
54
发表于 2022-6-30 12:33:06 | 显示全部楼层 |阅读模式
【报错】error: unable to recognize "work1.yaml": no matches for kind "Deployment" in version "extensions/v1beta1"

之前一直使用work1.yaml文件 没有任务问题,但今天突然apply报错了 老师救命啊这个java的Demo起不来啦!老大要看演示 急 急
回复

使用道具 举报

5

主题

41

帖子

190

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
190
发表于 2022-6-30 12:36:45 | 显示全部楼层
刚看到问题,不要着急有我在 是不是k8s集群更新了。更新过了?
【解决办法】
#查看现在k8s支持apiversion版本
[root@k8s-master ~]# kubectl api-resources  |grep deployment
deployments                       deploy       apps/v1                                true         Deployment

#修改文件work1.yaml
apiVersion: apps/v1

重新apply -f 一下,如果解决不了 ,我发誓从此以后我再也不吃辣条了。 哈哈
回复

使用道具 举报

7

主题

15

帖子

54

积分

注册会员

Rank: 2

积分
54
发表于 2022-6-30 12:40:09 | 显示全部楼层
1秒钟解决问题 老师问答果然效率。进程起来了。 帅  
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

信息推荐

更多+

最新信息

更多+

峻熙闪答-公众号

官方微信

联系我们:

15131265091

公司地址:河北省保定市竞秀区

Email:1547462309@qq.com

备案:冀ICP备17015524 &技术支持:峻熙闪答